Adobe Connect

Access to Adobe Connect

Adobe Connect is a web conferencing platform for web meeting, eLearning, and webinars. The current version is Adobe Connect 10.5 and supports:

  • Slides
  • Documents
  • Video (MP4)
  • Audio (MP3)
  • Annotations & Whiteboard
  • Courses (Adobe Presenter/Adobe Captivate)

Requirements for Adobe Connect:

Headsets

For best results using Adobe Connect, please use a USB headset/microphone. This will minimize or eliminate feedback or extraneous background noise. Below are examples from Logitech that are recommended, though many other high-quality options are available at reasonable prices.

Webcam

When using Adobe Connect having a webcam is necessary to share a video of yourself. Adobe Connect recognizes and utilizes many built-in or USB webcams.

Requirements

Windows

  • 1.4 GHz Intel Pentium 4 or faster processor (or equivalent)
  • Windows 10, 8.1 (32-bit/64-bit), Windows 7 (32-bit/64-bit)
  • 512 MB of RAM (1 GB recommended)
  • Microsoft Internet Explorer 11 or later, Windows Edge browser, Mozilla Firefox, and Google Chrome
  • For HTML Client - Google Chrome (v66.0 or above), Mozilla Firefox (v55.0 or above) and Edge (EdgeHTML v16 or above)

Mac OS

  • 1.83 GHz Intel Core Duo or faster processor
  • 512 MB RAM (1 GB recommended) 
  • Mac OS X 10.11, 10.12, 10.13 and 10.14
  • Mozilla Firefox, Apple Safari, Google Chrome
  • For HTML Client - Google Chrome (v66.0 & above), Apple Safari (v11.0 & above) and  Mozilla Firefox (v55.0 & above) 

Mobile

  •  The Adobe Connect app for iOS and Android requires Adobe Connect Server version 8.2 or later
  • Some features may not be enabled in all Adobe Connect meetings if one is using an Adobe Connect Server older than version 9.4.2 (required for Custom pods)
  • Google Android 4.4 or later
  • Apple iOS: iOS 8.1.2 or later

Additional requirements

  • Bandwidth: 512 Kbps for participants, meeting attendees, and end-users of Adobe Connect applications.
  • Connection: DSL/cable (wired connection recommended) for Adobe Connect presenters, administrators, trainers, and event and meeting hosts.
  • Adobe Connect account management by Meeting Hosts, Event or Webinar Managers, Virtual Classroom Managers, and Administrators requires Adobe Flash Player 13 or higher.

 Support

Adobe Connect Learn & Support

User Guide Articles